SCons release 3.0.1 now available from the download page at SourceForge. This release should be used instead of 3.0.1. This release fixes several issues. TThis will be the first release to support Python versions earlier than 2.7 as well as 3.5+. You can view ChangeLog

Note that due to many changes needed to support both 2.7 and 3.5+ switching python between 2.7 and 3.5+ will cause rebuilds of some targets.